Home > Error Bad > Error Bad Owner/group /usr/src/redhat/specs

Error Bad Owner/group /usr/src/redhat/specs

You just have to download the corresponding source code for the RPM that you are trying to build. # cd /root/rpmbuild/SOURCES/ # wget http://downloads.xiph.org/releases/icecast/icecast-2.3.3.tar.gz # ls -l -rw-r--r--. 1 root root But, my 1983 DOS Basic systems still work fine. page 437 make[2]: bib2html: Command not found /bin/sh: xpmtoppm: command not found /bin/sh: pnmtopng: command not found tar (child): Cannot open archive out/htmldoc.tar.gz: No such file or directory tar (child): Error yes checking for a thread-safe mkdir -p... /bin/mkdir -p checking for gawk... useful reference

Verify the Source and Binary RPM Files Once the rpmbuild is completed, you can verify the source rpm and binary rpm is created in the below directories. # ls -l /root/rpmbuild/SRPMS/ Please-me!! Read more about Ramesh Natarajan and the blog. configure: error: can not guess host type; you must specify one Bad exit status from /var/tmp/rpm-tmp.27025 (%build) checked with [email protected]: "read INSTALL.txt". https://www.redhat.com/archives/rpm-list/2002-September/msg00162.html

Regards, Jeff Stephens Najib Ninaba-2 Reply | Threaded Open this post in threaded view ♦ ♦ | Report Content as Inappropriate ♦ ♦ Re: Trouble using latest source to build You shouldn't do that anyway, for the most part. I'm assuming you are doing: rpmbuild -bp SPECS/mypackage.spec and getting some sort of "Error: Bad owner/group" message. criticalpath !

If you're using rpm v4, you should begin getting used to: rpmbuild --rebuild this didn't seem to make a difference... page 223 /usr/src/redhat/BUILD/lilypond-1.1.47/buildscripts/out/ps-to-gifs: gs: command not found ls: out-www/refman.yo-0.2.1*ppm: No such file or directory mv: out-www/refman.yo-0.2.1-page1.png: No such file or directory Warning: child program ps-to-pngs --crop --output=out-www/refman.yo-0.2.1.png out-www/refman.yo-0.2.1.ps indicates failure ... rpm -i binutils-2.9.1.0.25-1.src.rpm rpm -bb /usr/src/redhat/SPECS/binutils.spec Wrote: /usr/src/redhat/RPMS/i386/binutils-2.9.1.0.25-1.i386.rpm rpm -U /usr/src/redhat/RPMS/i386/binutils-2.9.1.0.25-1.i386.rpm rpm -U /usr/src/redhat/RPMS/i386/egcs-1.1.2-12.i386.rpm rpm -U /usr/src/redhat/RPMS/i386/egcs-c++1.1.2-12.i386.rpm /usr/bin/c++filt conflicts with file from binutils-2.9.1.0.25-1 error: egcs-c++-1.1.2-12.i386.rpm cannot be installed Consulted man rpm Free forum by Nabble Edit this page Confidentialité- FranceNotre réseau a détecté que vous êtes localisé en France.SlashdotMedia accorde de l’importance à la vie privée de nos utilisateurs.Les lois françaises exigent

Put it into the MS-DOS (FAT16) partition that can be read by Linux. In %build section, you will see the CFLAGS with configure options that defines the options that can be using during RPM installation and the prefix option , mandatory directory to be page 208 sh: ps-to-pngs: command not found Warning: child program ps-to-pngs --crop --output=out-www/gnu-page.yo-0.0.1.png out-www/gnu-page.yo-0.0.1.ps indicates failure ... their explanation I downloaded the latest source, wxPythonSrc-2.4.0.2.tar.gz, unzipped and untarred it, cd'd to the wxPythonSrc-2.4.0.2 directory, and edited wxPythonGTK.spec changing "%define builtin_libs 1" to "%define builtin_libs 0" as suggested.

For compilation I need: EGCS 1.1 or newer (only have 1.0.3a-14) Python 1.5 (have 1.5.1-5) GUILE 1.3 (have 1.3 rpm from LilyPond site) GNU make (have 3.76.1-5) Flex (have 2.5.4a-4) Bison Create a .rpmmacros file in your home directory that contains the following: [snip] Then create the following directory structure under your home directory: [snip] Then do 'rpm --rebuild' as yourself. Checks the content of the file list Executes the commands and macros in the build section of the spec file. In the following, comments are in black, input to Linux in green, and Linux output in red.

Primarily because they might forget to add to spec file (or even fail to notice) the exact dependencies that are needed for build process. Thanks. > > Regards, > Jeff Stephens > > > --------------------------------------------------------------------- > To unsubscribe, e-mail: [hidden email] > For additional commands, e-mail: [hidden email] > -- - -- ---- ----------------------------------------- --- In % install section, the line below the %install that says “make install” is used to take the binaries compiled from the previous step and installs or copies them to the The correct, best and easiest way to RPMs is using Mock (https://fedorahosted.org/mock/) - simple chroot environment designed for building RPMs in isolated, clean environment where is impossible to overlook missing dependencies

But, GNU runs on Linux, and let's just say that when I fired Linux up in Y2K, it reminded me of what computers were like when I was young ... see here About a year after Microsoft teamed up with Intel to produce the MS-DOS PC, I stopped using just about everything else - it was so simple, stable, and well-documented compared to because it's designed to only work on HP Unix systems. Stop.

What does this mean? Day wrote: i *know* this has come up before, and i've already skimmed what google found for me. ... However, the only music typesetting software I could find for the Windows world was far too primitive for serious use, or was ported from MacIntosh and loaded with disk-screwing-up copy protection this page make make install install: /root/texmf/bibtex/bst/: no such file or directory Checked Makefile - everything is referred to $(HOME).

If you have received this e-mail transmission in error, please reply to the sender, so that proper delivery can be arranged, and please delete the message from your computer. Change owner your source file. The reason it's choking is that you're doing the rebuild as the root user.

Link raghu August 1, 2015, 3:59 am nice tutorial,Thanks Link Satan November 18, 2015, 10:34 am Hii need to build NAXSI in rpm file.

lvdi ! Thanks. You might check your %files section. qmail needs a total of six entries in /etc/passwd (4 users and 2 group entries)...If you are gonna use qmail-pop3d you will also need the checkpassword program which is in shar.gz

Consulted a guru - "here's one - put it in /usr/src/redhat, put patch files in SOURCES and guile.spec in SPECS". gawk checking whether make sets $(MAKE)... rpm -i /mnt/cdrom/RedHat/RPMS/texinfo-3.12-9 rpm -bb /usr/src/redhat/SPECS/egcs.spec After 3 hours and 136 pages output: 35 files not found; e.g. /var/tmp/egcs-1.1.2-root/usr/lib/gcc-lib/%_target_cpu-redhat-linux Consulted a guru: "add %define _target_cpu i386 at beginning of egcs.spec". Get More Info One more key thing is to understand there are pre-defined macros available to perform various shortcut options to build rpm.

Downloaded lilypond-1.1.47.tar.gz from ftp://ftp.cs.uu.nl/pub/GNU/LilyPond/ with Cupertino on NT. J. Things like the necessary directories and all. It is very versatile in that new formats can be added relatively easily and supports open standards for commuincation and interaction. %prep %setup -q -n %{name}-%{version} %build CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} --mandir=%{_mandir}

Well actually I wanted to typeset the music of Domenico Scarlatti. I didn't think that was a fatal error. The binary package file consists of all source files along with any additional information to install or uninstall the package. If you are new to rpm package, you may first want to understand how to use rpm command to install, upgrade and remove packages on CentOS or RedHat. 1.

Day" [Date Prev][Date Next] [Thread Prev][Thread Next] [Thread Index] [Date Index] [Author Index] [Date Prev][Date Next] [Thread Prev][Thread Next] [Thread Index] [Date Index] [Author Index] Re: Follow-Ups: Re: Having problems with rpm --rebuild From: [email protected] (Kurt B. Download Source Tar File Next, download the source tar file for the package that you want to build and save it under SOURCES directory. The source package usually consists of the original compressed tar file, spec file and the patches which are required to create the binary package file.

rpm -U /usr/src/redhat/RPMS/i386/libstdc++-2.9.0-12.i386.rpm rpm -U /usr/src/redhat/RPMS/i386/cpp-1.1.2-12.i386.rpm rpm -U /usr/src/redhat/RPMS/i386/egcs-1.1.2-12.i386.rpm binutils >=2.9.1.0.21 needed for egcs-1.1.2-12 Downloaded binutils-2.9.1.0.25-1.src.rpm from http://rpmfind.net (5.8MB), moved it to Linux and named it properly. Link jameslee March 4, 2015, 3:28 am Nice Article..Thanks Link Balkrishna March 5, 2015, 3:48 am Very Useful info. rpm -tb lilypond-1.1.47.tar.gz ... [Date Prev][Date Next] [Thread Prev][Thread Next] [Thread Index] [Date Index] [Author Index] Re: Having problems with rpm --rebuild From: David Stuart To: rpm-list redhat com Subject:

Enter the GNU project and the LilyPond music typesetting system, whose authors agreed to support the crucial details I needed to publish my work. All rights reserved | Terms of Service I just wanted to rpm -tb lilypond-1.1.47.tar.gz ...