Home > Error Accessing > Error Accessing Sound Input From /dev/dsp

Error Accessing Sound Input From /dev/dsp

The problem behind the problem is: how can I record sound from the microphone with xvidcap? Selected driver: v4l2 name: Video 4 Linux 2 input author: Martin Olschewski comment: first try, more to come ;-) v4l2: your device driver does not support VIDIOC_G_STD ioctl, VIDIOC_G_PARM was When stating a theorem in textbook, use the word "For all" or "Let"? Hmm ... More about the author

To rule out other problems, such as with the microphone, I tried with gnome-sound-recorder and it works. Reply With Quote 15-Dec-2011,21:11 #7 blade2 View Profile View Forum Posts View Blog Entries View Articles Newcomer Join Date Nov 2008 Posts 47 Re: Xvidcap not working in opensuse 12.1 Thanks Cheers, Doug Doug Hutcheson View Public Profile Find all posts by Doug Hutcheson #7 30th December 2010, 12:18 PM oldcpu Offline Registered User Join Date: Jan 2009 Location: Thanks so much for sticking with this - I may get it working yet! dig this

students who have girlfriends/are married/don't come in weekends...? I find mencoder renders a slightly better video than ffmpeg at 640x480 resolution. Developer IT xvidcap: Error accessing sound input from /dev/dsp - Developer IT Home | Community | Contact | Site map HomeOur blogsTop 50Submit your site/blogArchivesContact usStatistics Search Box Who's amung us? No, thanks Web Projects Outsourcing FacebookWeb Projects Outsourcing TwitterWeb Projects Outsourcing Google PlusWeb Projects Outsourcing PinterestWeb Projects Outsourcing LinkedInWeb Projects Outsourcing FlickrWeb Projects Outsourcing TumblrWeb Projects Outsourcing RSS Search Web Projects

Did anyone managed to get 3D acceleration work under VMWare workstation 8? Ideally, xvidcap should use PulseAudio for audio input, failing that it should use Alsa. A more helpful error message might help, but at least I am making progress now. v4l2: Cannot get fps Channel count not available - reverting to default: 1 Channel count not available - reverting to default: 1 Floating point exception (core dumped) To my inexperienced eye,

Regards Adv Reply Page 1 of 2 12 Last Jump to page: Quick Navigation Desktop Environments Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums After clicking OK make sure to save preferences (by right clicking on test-0000.mpeg button again). If you would like to refer to this comment somewhere else in this project, copy and paste the following link: David Liontooth - 2003-12-15 Logged In: YES user_id=897748 Sound works fine Doug Doug Hutcheson View Public Profile Find all posts by Doug Hutcheson #5 30th December 2010, 10:01 AM oldcpu Offline Registered User Join Date: Jan 2009 Location: Europe

Join Date Mar 2011 Beans 70 another option for gnome-sound-recorder Another option, not to have to change once and again between Analog Stereo Duplex and Analog Stereo Output neither limit the And then send this ffmpeg command: Code: ffmpeg -f alsa -ac 2 -i hw:1,0 -f x11grab -r 30 -s 1440x900 -i :0.0 -acodec pcm_s16le -vcodec libx264 -vpre lossless_ultrafast -threads 0 output.avi Best way for an external (remote) graphics designer to style ASP.NET MVC 4 app? Like the stated for padsp xvidcap, to change where we want to record the sound from, we put gnome-sound-recorder recording, open pavucontrol and in the Recording tab we put the desired

You can see that from my mixer settings for the webcam: Code: !!-------Mixer controls for card 1 [U0x46d0x821] Card hw:1 'U0x46d0x821'/'USB Device 0x46d:0x821 at usb-0000:00:1d.7-2, high speed' Mixer name : 'USB http://www.rationalplanet.com/linux/xvidcap-in-fedora-11-error-accessing-sound-input-from-devdsp.html It works fine in 11.3. Ever.RDO Newton Overcloud HA deployment via instack-virt-setup on CentOS 7.2 VIRTHOSTBeanDuino: Tiniest Arduino compatible ever?Top 10 Communities To Help You Learn Linux Web Projects Outsourcing FacebookWeb Projects Outsourcing TwitterWeb Projects Outsourcing Sorry to read it did not work.

v4l2: ioctl enum norm failed: Invalid argument Error: Cannot set norm! my review here Synchro is still a problem, but I have something to work with and will, no doubt, find the solution. would work and hey, presto! There is no sound from this adapter at the present, although it worked just before on the previous installation.

Thanks very much for posting this trick. Quote: Originally Posted by Doug Hutcheson Well, I'll be ...! You will have to register before you can post in the forums. (Be aware the forums do not accept user names with a dash "-") Also, logging in lets you avoid http://axishost.net/error-accessing/error-accessing-ole.php Cheers, Doug ---------- Post added at 01:29 PM ---------- Previous post was at 12:48 PM ---------- Quote: Originally Posted by Doug Hutcheson ffmpeg is now recording sound using alsa and device

I forgot to mention. Then what one needs to do is move the application to the upper left hand corner of one's KDE4 desktop. The driver support of this GFX chipset has always been poor and mainly community-driven, now finally we have a KMS open-source… >>> More Error Ubuntu 11.10 despues de instalar [Error after

Well, I'll be ...!

At least I know avidemux does work, at least. v4l2: Cannot get fps ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM /dev/snd/pcmC0D0c Error opening audio: No such file or directory ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM /dev/snd/pcmC0D0c Error opening audio: No such file or Sadly, the .avi files saved by VLC in record mode can't be opened and they are the closest I got to correctly synched audio. This will then size the window to be exactly 1440x900 resolution.

So on an openSUSE-11.4 system (core i7 920 cpu), I played back the TV at full screen (1920x1200) and captured it with this command: Code: ffmpeg -f alsa -ac 2 -i Whether it is coincidence or not, ffmpeg is now recording sound using alsa and device 'default', 'hw:0,0' and 'hw:1,0'. Doug Hutcheson View Public Profile Find all posts by Doug Hutcheson #3 29th December 2010, 06:29 PM oldcpu Offline Registered User Join Date: Jan 2009 Location: Europe Posts: navigate to this website My observation of what has partly worked so far is that the sound/video synch can 'drift', starting close and ending out of synch after some minutes.

Please note that you will need that command any time you are going to use xvidcap, it does not have any effect after the reboot, you will have to re-issue this How to mix correctly? UTF-8 problem perhaps? I will have to keep one eye on my other multimedia apps, to see if they have problems with the oss module. ---------- Post added at 12:48 PM ---------- Previous post

Adv Reply March 27th, 2011 #5 vezolmi View Profile View Forum Posts Private Message Just Give Me the Beans! Thread Tools Search this Thread Display Modes #1 27th December 2010, 04:03 AM Doug Hutcheson Offline Registered User Join Date: Jun 2009 Location: Queensland Posts: 232 Which device or b) Go to preferences (right clicking on the name of the file, for example test-0000.mpeg, and then cliking on Preferences), then to the Commands tab, and then in the "Multi-Frame I have cracked ffmpeg!

Page 1 of 2 12 Last Jump to page: Results 1 to 10 of 11 Thread: xvidcap audio does not work Thread Tools Show Printable Version Subscribe to this Thread… Display I figured out that the equivalent to /dev/dsp under alsa is /dev/snd/pcmC0D0c (card zero, device zero, capture) and, similarly, ~C1D0c for the other device (usually my webcam). If you launch that from the command line you notice an error message: Shell [[email protected] ~]$ xvidcap Error accessing sound input from /dev/dsp Sound disabled! 123 [[email protected] ~]$ xvidcapError accessing sound To rule out other problems, such as with the microphone, I tried with gnome-sound-recorder and it works.

Fedora 14 Quote: Originally Posted by oldcpu Sorry to read it did not work. Some of the clips recorded by various tools just plain don't open - just get a "can't open file" complaint. I don't know. Join Us!

Perhaps the answer is to either (a) find some other capture software, or (b) see if you can capture without sound, and then use a video editor to combine the sound In desperation, I now want to try ffmpeg. Update stops. I tried it just now and got an error: Code: $ mencoder tv:// -tv driver=v4l2:width=320:height=240:device=/dev/video0:forceaudio:immediatemode=0:alsa:adevice=hw.1,0 -ovc lavc -oac mp3lame -lameopts cbr:br=64:mode=3 -o webcam.avi MEncoder SVN-r31628-4.4.4 (C) 2000-2010 MPlayer Team success: format: